S410 presure gauge

User avatar
david.j.stewart
Posts: 3
Joined: Wed Dec 12, 2018 7:10 am
Location: co durham

S410 presure gauge

Mon Dec 02, 2019 3:03 pm

had a problem with my drivers bottle had a fault on the on off tap as a result the gun was over charged damaged the air cylinder that has now been replaced with a new one and all new seals
also replaced the pressure gauge as it was off the clock.
I removed the old pressure gauge and its gone back to empty , as I had purchased a new replacement gauge.
refilled the rifle but again it was just over 200 and the max should be 190.
used the rifle at the weekend fired fired off around 50 shots at a target the gauge never moved ?? :( still on 200

no avatar
Jammy13
Posts: 26
Joined: Tue Jul 02, 2019 5:00 pm
Location: Northumberland

Re: S410 presure gauge

Wed Dec 04, 2019 7:22 pm

My first thought is your diver bottle has a gauge fault and is putting more pressure into the rifle than you think. If I'm correct you will have come very close to blowing the new cylinder.

Dry fire the rifle and see if its gauge starts to drop. If it does, refill the rifle from someone else's diver bottle to 190bar and see what the rifle gauge reads. If it reads 190bar or thereabouts replace your diver bottle gauge.

Check the new rifle cylinder for damage. There is also a chance you have damaged the new rifle gauge if you dry fire till the rifle is empty and its gauge still reads anything other than empty.

Keith

User avatar
david.j.stewart
Posts: 3
Joined: Wed Dec 12, 2018 7:10 am
Location: co durham

Re: S410 presure gauge

Sat Dec 07, 2019 9:46 pm

correct m8 the over charge damaged the air cyclinder both ends fluted.
a new air cylinder has been fitted and all neal seals + a new pressure gauge
whent back to the diving centre for them to check the bottle as its just over a year old, no problems found on the kit
gun has been charged again to just under 190 .
my grandson uses the gun as I purchased a brand new rifle in may ( not a day state) so needed the rifle check out for safety
I pruchased the S410 years ago and it was an older s410 model its around 14 year old think I am the third owner, been out today up the farm and its working fine
thank you for the info

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests