AA S510 ult sporter Sope mount problems

no avatar
imnobody
Posts: 1
Joined: Thu Nov 30, 2017 8:16 pm

AA S510 ult sporter Sope mount problems

Thu Nov 30, 2017 9:26 pm

Has anyone else had this problem? I mounted a Hawke SideWinder 30 scope with BKL rings on my rifle. When I got it sighted in at 25 yards I found that I had only one full turn of the windage knob left. There is 4 1/2 turns on the windage nob. When zeroed you should be near center and not have most of the windage used up. I tried 3 other sets of rings and 2 other scopes with the same results. I sent the rifle back and it was replaced with a new one and I have the same problem.

I have over 50 years in the firearms industry as a gunsmith and store owner. I'm putting this out to see if anyone else has had this problem and fixed it. If not I will start and see if I can figure it out. The gun is very quiet and shoot well. I intend to use it to shot ground squirrels. Forgot to mention it is in 25 cal.

Thanks for your help.

User avatar
Blackbaronfish
Posts: 3185
Joined: Sun Feb 15, 2015 6:20 pm
Location: Nuneaton

Re: AA S510 ult sporter Sope mount problems

Thu Nov 30, 2017 10:15 pm

Have you got the right size for the dovetail.
Have you tried it on another rifle
Have you tried another scope on the rifle and rings

BBF
Did I mention that I'm the only one to have attended EVERY annual meet since we started

User avatar
TenMetrePeter
Posts: 816
Joined: Wed Jun 29, 2016 5:40 pm
Location: Luton Beds UK

Re: AA S510 ult sporter Sope mount problems

Thu Nov 30, 2017 11:10 pm

Have you tried having front ring clamp screws facing right and rear ring screws facing left. And vice versa.
Assuming 2 piece rings of course.
S400 MPR Precision with TMP alloy stock.

https://www.youtube.com/channel/UCaCf9G ... A-mGhZQlGw

no avatar
Roger5
Posts: 709
Joined: Sat Jul 25, 2015 8:04 am
Location: Hampton middlesex

Re: AA S510 ult sporter Sope mount problems

Thu Nov 30, 2017 11:34 pm

Take the moderator off, check the alignment of the barrel inside the shroud, it might look like it's not central in the shroud, if so slacken shroud off slightly and refit mod, works for me. Rog

no avatar
Archer50
Posts: 137
Joined: Mon Jun 20, 2016 5:06 pm
Location: Perth

Re: AA S510 ult sporter Sope mount problems

Sat Dec 02, 2017 1:24 pm

Assuming your pellet went low when your scope was optically centred, it is probably not a fault, it simply shows that on most guns the sight mounting dovetail is parallel with the barrel. For the optical centre to coincide with the POI, the scope would have to be pointing downwards slightly.

If you are worried about optical centring or if you just run out of adjustment - and this is exactly what happened with my Sidewinder 30 - the answer, as I'm sure you know is shimming the rear mount or getting an adjustable mount. Hawke themselves make sloped mount inserts for both 25 and 30 mm tubes https://uk.hawkeoptics.com/mount-inserts-30mm.html which shim the rear by 25 moa with much less danger of bending or crimping the tube than using photo film or whatever. I have used these on my HFT 500 (with a Sidewinder) and on my Steyr (with a Sightron SIII) and found on both that the 25 moa brought my POI within less than a quarter turn of the turret of the optical centre. I will probably use these inserts as standard from now on.

Hope this helps.

Alan

User avatar
Blackbaronfish
Posts: 3185
Joined: Sun Feb 15, 2015 6:20 pm
Location: Nuneaton

Re: AA S510 ult sporter Sope mount problems

Sat Dec 02, 2017 1:35 pm

Windage :mrgreen:

BBF
Did I mention that I'm the only one to have attended EVERY annual meet since we started

no avatar
Archer50
Posts: 137
Joined: Mon Jun 20, 2016 5:06 pm
Location: Perth

Re: AA S510 ult sporter Sope mount problems

Sat Dec 02, 2017 3:59 pm

Blackbaronfish wrote:Windage :mrgreen:

BBF



Oops. And I hadn't even had anything to drink! Please ignore the brain fart!

User avatar
Blackbaronfish
Posts: 3185
Joined: Sun Feb 15, 2015 6:20 pm
Location: Nuneaton

Re: AA S510 ult sporter Sope mount problems

Sat Dec 02, 2017 5:01 pm

Must be the downdrafts :lol: :lol: :lol:

BBF
Did I mention that I'm the only one to have attended EVERY annual meet since we started

no avatar
supergnome
Posts: 14
Joined: Sat Jan 28, 2017 9:47 am
Location: north Lincs

Re: AA S510 ult sporter Sope mount problems

Tue Dec 05, 2017 6:54 pm

Is it fac, if not, 0.25 is not the best calibre for past 35m.
I've had 3 different scopes on mine and not had any problems.the mounts were Sportsmatch medium swan neck ( front mount ). Had to shim the bottoms so as to clear the mag post.Scope now using is Zos 10-40X50.
David

p.s. shoots to the left about 20cm at 50m. Groups within 5cm with JSB exact 15.9gn in 5,52 diam.
FTP 900
64 MPR

no avatar
Lon'gun
Posts: 0
Joined: Sun Oct 22, 2017 10:36 am

Re: AA S510 ult sporter Sope mount problems

Sat Dec 30, 2017 4:41 pm

Have you checked the barrel clamp grub screws for tightness.?
Maybe the barrel has moved off centre.
https://www.youtube.com/watch?v=LNdYqVHiRBg

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests