510 indexing post / mag clip problems

no avatar
Lord Long
Posts: 43
Joined: Mon Feb 16, 2015 8:21 am

510 indexing post / mag clip problems

Sat Sep 22, 2018 1:58 pm

Just of late I've had a few problems with indexing the mag , I put a new post in, which works 90% of the time, but doesn't spin the mag every so often . Also today (first time out with new index post) it started 'spitting' the mag out. It improved a bit over the mornings shooting, but is still doing it on an intermittent basis. It was suggested to bend the mag clip down a little bit to help hold the mag in. This did help a bit but it is still both missing an index and spitting the mag out every so often . Any ideas ..thanks.
Air Arms S510 30th Anniversary .177
Air Arms S410 Carbine .177

User avatar
Blackbaronfish
Posts: 3222
Joined: Sun Feb 15, 2015 6:20 pm
Location: Nuneaton

Re: 510 indexing post / mag clip problems

Fri Sep 28, 2018 8:10 pm

The magazine should click into place as the mag engages the retaining clip. If it wont then clean the crud from under the clip and see if it also needs adjusting.
Is the spring an original as there are some rogue ones that use a heavier spring steel and its then counter productive.
The magazine should be easy to rotate and a little clean and spray lube can pay dividends.
A neat trick is to remove a coil from the original spring as the ball bearing sits too heavy in the grooves. If you do this mod please do it in a clear plastic bag to prevent the bearing from flying into the air and being lost :o .
The magazine spring sometimes needs slightly bending back into shape and can only be done by looking at the spring when you pull the lever.

I hope these few pointers help

BBF
Did I mention that I'm the only one to have attended EVERY annual meet since we started

User avatar
eyeonthetarget
Posts: 6
Joined: Sun Sep 30, 2018 10:46 am

Re: 510 indexing post / mag clip problems

Mon Oct 01, 2018 7:44 pm

Hi,
Air Arms have modified the index post - it looks completely different now - I would fit that for starters.
Best ask the Factory where to get one as I guess there are a lot of the old ones out there !

no avatar
Lord Long
Posts: 43
Joined: Mon Feb 16, 2015 8:21 am

Re: 510 indexing post / mag clip problems

Sat Nov 03, 2018 3:27 pm

Sorry to come back to this thread late, and I appreciate all the suggestions put forward, I seem to have sorted the problem with my 510, so obviously nothing goes smoothly and today my 410 decided to break its index post. Luckily my shop had one, so I replaced it at the range. Problem is, now when I replace the three cam cover bolts (is that what you call it) the bolt is stiff and hard to cock when the bolts are done up. When I got home I stripped it out again, degreased, checked nothing was stuck under the cam cover, (which there wasn't) regreased sparingly and reasembled. Still stiff to cock, if I loosen off the bolts,all is well. Any ideas ? Also interested in the new index post, think I'll have to try and locate some. Thanks.
Air Arms S510 30th Anniversary .177
Air Arms S410 Carbine .177

no avatar
Harley
Posts: 7
Joined: Mon Oct 30, 2017 3:29 pm

Re: 510 indexing post / mag clip problems

Tue Nov 13, 2018 6:45 pm

I too have had a indexing post break whilst shooting. Lesson learnt, since that time I now carry a spare and an allen key.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest